I suggest you ...

Solve the Word 365/2016 Slow Typing Issue

Since Word 2016 was published, it has very serious performance issues on devices with high resolution displays like the Surface Book and Surface Pro. As soon as a document is longer than about 1000 words, there is a terrible typing lag, i.e. text appears on screen much slower than you type.
The typing lag is particularly bad in tables and when markup mode is used.
This bug is a terrible productivity killer. I can absolutely not understand how it can persist since mid 2015 without being corrected, even more since it mainly appears on Microsoft hardware.

The bug is reproducible. All Surface Books in our company suffer from it. Even a fresh install of the most recent versions of Windows 10 und Office 365 does not solve the problem.

The bug has been extensively discussed on answers.microsoft.com, but no solution is known so far.
See for instance in these threads:

https://answers.microsoft.com/en-us/msoffice/forum/msoffice_other-mso_winother/2016-typing-lag/0e44d2f2-1f6f-43d1-8592-6fae7345bc4f?page=2

https://answers.microsoft.com/en-us/msoffice/forum/msoffice_word-mso_win10/2016-office-slow/ceb6326d-f713-4769-87f1-cff137168708

https://answers.microsoft.com/en-us/msoffice/forum/msoffice_word-mso_mac/word-2016-cursor-movement-slow-jumpy-laggy-erratic/f19195dd-564f-48b4-bf89-de8191c70f44?page=15

A solution would be very much appreciated! Thanks.

760 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Matthias HaldimannMatthias Haldimann shared this idea  ·   ·  Admin →

    127 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • RussRuss commented  · 

        I'm using Word for Mac Version 15.39 through Office 365. As I type, random letters and spaces don't show on the screen, so I'm having to constantly go back to fix them. The problem is that words that are misspelled because of dropped letters or spaces don't show as being misspelled, and they aren't picked up in spell check. It really slows down typing and I don't catch them all, so the finished document has errors that I missed, and don't even show up with a spell check. This has only been a problem the past few days, and seems to coincide with the most recent update.

      • RosieRosie commented  · 

        Been using Word 2013 to write up my PhD; at approximately 55,000 words (I hit this yesterday) I've started to experience terrible typing lag but predominantly on this one large document. I've tried the advice suggested about turning off Display Hardware Graphics (Zepelda below) but it's not helping. My netbook is slow anyway but all the software is up to date and it ran MS perfectly efficiently til a day ago or so. I'm panicking here because I don't have a lot of time to tinker around with patches or alternate versions of this programme. Can anyone help?

      • Angry StudentAngry Student commented  · 

        Im using Microsoft office 365 word online to do school work, i have the same issue in word online but the thing is, there is no way to disable hardware acceleration since you can,t get into "options" in word online. How am i supposed to finish my studies now Microsoft? And using the regular (not online version) word is out of picture since i don't have a subscription and can't really afford one at the moment.

      • HarryHarry commented  · 

        I have found that if you have spotify open as well as word it makes my writing lag. This only happens when I am listening to a large playlist (500 songs). I changed playlist to one with less songs in it and the lag on word stopped. Has this happens to anyone else or could this be an issue isolated to my computer?

      • Anonymous commented  · 

        Same issues here - Win 7 Ultimate, x64. I cannot get more than 20 seconds of typing in and then blam, 2 to 3 minutes of spinning, hanging, and lag time. I have tried all the fixes suggested in these threads, and NOTHING has helped at all. MS, I am a professional writer and this is seriously impacting my bottom line. I have to hope that I can find an earlier version of Word and use that because I did NOT have these problems at all in Word 2010 with such large documents. When is this going to be addressed? It's almost over and done in 2017 and still no fix? Who tests this cr*p before it goes live to market?

      • Anonymous commented  · 

        This problem must be fixed by Microsoft. Word 1016 is unusable for serious writers/workers.

      • VinceVince commented  · 

        Followed the advice by Zepeda below and it worked. For your convenience:
        Start Word 2016.
        On the File tab, click Options.
        In the Options dialog box, click Advanced.
        In the list of available options, click to select the Disable hardware graphics acceleration check box. ...
        Click OK.

      • Guillermo ZepedaGuillermo Zepeda commented  · 

        The solution that worked for me is posted below.

        Disable hardware acceleration internally in word.

        Many months of suffering!

        To disable hardware acceleration, follow these steps:
        Start Word 2016.
        On the File tab, click Options.
        In the Options dialog box, click Advanced.
        In the list of available options, click to select the Disable hardware graphics acceleration check box. ...
        Click OK.

      • edcclubedcclub commented  · 

        If MS really cared about us, they would offer a version of Word that 99% of us need. We do NOT need all the bells and whistles that some young software engineer figured out how cool it would be. Most of these developers have not been using Word for decades or even a few years. All they are about is capability --- the more the better. Stop the nonsense. Simplify!

      • IgorKIgorK commented  · 

        The problem with scrolling the Word 2016 document appeared again when I deleted the existing table from the document and Copy-Pasted new table from Excel. This time saving as doc and back as docx did not solve the problem. So I deleted the table and tested the scrolling of the document. Scrolling without the table present was smooth. Now I used Copy-Past Special-Formatted Text (RTF) sequence to paste the Excel table into the docx and checked the scrolling again. Surprisingly, scrolling was smooth.

        I hope it is helpful.

      • IgorKIgorK commented  · 

        It seems I solved this problem. I saved my Word 2016 docx file as doc and then back as docx. It seems to be working fine now.

        Let me know if it works for you too, please.

      • Maria SMaria S commented  · 

        Please, please fix. There is no point to Word if it can't at least keep up with our fingers. It's jerky and disconcerting and if you want to delete a sentence it takes FOREVER by which point you've forgotten where you were going with the whole thing. I'd reinstall Word 2006 if I could.
        Jeez, who betas these things?

      • Angry RobAngry Rob commented  · 

        I'm running office on a very fast desktop pc (Dell) and this is getting to the point where I'm thinking of cancelling my subscription.

        I have to wait 7 seconds to clear out a cell in a table? I'm trying to write a dissertation here!

        FIX YOUR CODE.

      • Mike GalloMike Gallo commented  · 

        I have this same exact issue in OneNote, and with the same exact symptoms and response to treatment. In large OneNote pages, there begins a delay in typing characters. This delay is present only when editing the large page and not in smaller ones. The lag is not alleviated until the material on the large page is split into separate pages, at which point the lag disappears. This does appear to be an unresolved known issue. Please fix this, Microsoft. Cortana will thank you. So will I.

      • Harry F. MuddHarry F. Mudd commented  · 

        Windows 10 x64, Office 2016 x86.

        I fought this for a year, tried every solution listed here and anywhere else I could find. Finally uninstalled Word from Office 2016, then installed only the Word component from Office 2010.

        It's wonderful when the pain stops.

        Office 2010 is on extended support (i.e. gets security updates) until Oct 2020. Hopefully this issue will be dealt with by then.

      • Peter.BPeter.B commented  · 

        I spoke with a Microsoft support agent,
        they told me to disable Graphics hardware acceleration from inside Word and that did the trick for me on Windows 10.

        Here are the steps to try;

        To disable hardware acceleration, follow these steps:
        Start Word 2016.
        On the File tab, click Options.
        In the Options dialog box, click Advanced.
        In the list of available options, click to select the Disable hardware graphics acceleration check box. ...
        Click OK.

      • Jack BrooksJack Brooks commented  · 

        It is complete and utter BS that Microsoft has STILL not fixed this problem!!!!

      • ScottScott commented  · 

        I have the same problem on all of the PCs I own, so clearly there should be no hardware bottleneck there. I've tried disabling animations, hardware acceleration and other things, still no luck. Running Office 365 from University place of work "Click to Run version". The devices on all of my displays are 1440p, but I have the same problem on my i7 4790K running at 4.8 GHz and with a GTX 1070. If I can run the latest games on Ultra at 144+fps, then I should be able to run Word!

      • Rick W.Rick W. commented  · 

        This may not be the problem that anyone else here is having, but I'll pass it along for the general help it can be.

        The typing was so slow in a 11,000 word document I was editing that it was worse than typing on my old Android phone. I tried a much shorter document, and it was fine. I then opened a 112,000 word dissertation, thinking it may have been a problem of the length of the mss . . . and it typed just fine! So, thinking there might be a formatting issue in the problem document, I tried the old fix of tapping Ctrl-End and then Ctrl-Shft-Home (which highlights the text but strips out some formatting stuck in at the very end), and copied and pasted it into a blank document, and all is well. This trick has saved me many a time with problem documents.

      • AnonymousAnonymous commented  · 

        Same problem with clean installed win 7 and MS office 2016

      ← Previous 1 3 4 5 6 7

      Feedback and Knowledge Base